Notes /

Upgrade Gatsby to Incremental Builds

On May 13, 2020 I upgraded my GatsbyJS to Incremental Builds using this guide: Enable Gatsby Incremental Builds on Netlify

My biggest problem was figuring out how to Enable Netlify Build Plugins.

When I went to select from the dropdown, nothing was visible. The problem was that my build image was set to Ubuntu Trusty 14.04, probably due to when I first setup my gatsby site, but in order to enable Netlify Build Plugins you have to be on Ubuntu Xenial 16.04. Once I switched the build image I was able to proceed with the guide without any issues.

Contact

Content is copyrighted 2019-2020 © D.S. Chapman. This site was built using GatsbyJS. Code for this website is open source and available on Github